Delay in email processing
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 19:55 UTC
Monitoring
We don't see any delay in email processing anymore, we're still actively monitoring the situation.
Posted Mar 26, 2020 - 16:26 UTC
Investigating
We currently investigate an issue with email processing
Posted Mar 26, 2020 - 16:20 UTC
This incident affected: SEND API and Incoming SMTP.