Degraded performance and delays with campaign sending and processing

Incident Report for Mailjet

Resolved

This incident had been resolved, the issue was identified and currently marked as resolved.
Posted May 06, 2023 - 10:31 UTC

Investigating

We are currently investigating an issue that impacts campaign sending and processing
Posted May 06, 2023 - 09:45 UTC
This incident affected: Mailjet App and REST API.