Message sending delays
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 21:18 UTC
Monitoring
The fix has been implemented and we are continuing to monitor the situation.
Posted Jan 13, 2021 - 20:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 13, 2021 - 19:03 UTC
This incident affected: Outgoing SMTP.