Delays in emails processing and general app.mailjet.com login issues

Incident Report for Mailjet

Resolved

The incident has been resolved. Any missing statistics during the incident haven't been lost and will show up in the statistics page later today.
Posted Sep 30, 2025 - 18:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 17:44 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 30, 2025 - 16:09 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 30, 2025 - 14:54 UTC

Identified

We have identified the root cause of the issue. While we are working on getting this resolved, clients will experience inability to log into app.mailjet.com as well as experience email processing delays.
Posted Sep 30, 2025 - 11:12 UTC

Update

We are continuing to investigate this issue.
Posted Sep 30, 2025 - 10:36 UTC

Investigating

We are currently investigating an issue impacting email processing along with app.mailjet.com login issues, reflecting into "wrong password" errors.
Posted Sep 30, 2025 - 10:21 UTC
This incident affected: Mailjet App, Website (Mailjet.com), SEND API, REST API, Outgoing SMTP, and Statistics Display.